Páginas

sábado, 15 de diciembre de 2012

Cómo actualizar las aplicaciones KDE en openSUSE

La distribución openSUSE tiene una política conservadora respecto a las actualizaciones oficiales. En general, no actualiza las versiones de las aplicaciones incluidas a no ser que sea para solucionar un problema de seguridad o para corregir un error importante. Es decir, que si queremos actualizar una aplicación a una versión superior que proporcione nuevas características, debemos recurrir a los repositorios no oficiales.

El equipo KDE proporciona nuevas versiones de las aplicaciones KDE que no forman parte de la compilación de software de KDE en el repositorio semioficial KDE:UpdatedApps. Este repositorio sólo es compatible con la versión del entorno KDE incluído con la distribución y es muy estable. Si se ha actualizado la versión de KDE incluída en la distribución, este repositorio no es necesario.

En este momento, en dicho repositorio se pueden encontrar, entre otras, versiones actualizadas de estas aplicaciones:
  • Amarok: reproductor de música.
  • Calligra Suite: suite de aplicaciones ofimáticas y artísticas.
  • eric5: entorno de desarrollo integrado para Python 3.
  • KDevelop: entorno de desarrollo integrado.
  • Kile: editor para el sistema de composición de texto Tex/LaTeX.
  • KMyMoney: gestor de contabilidad personal.
  • KNemo: monitor de red.
  • KRadio: reproductor de radio por Internet.
  • Krusader: gestor de archivos avanzado de doble panel.
  • KDESvn: cliente gráfico para el sistema de control de versiones Subversion.
  • Kst: herramienta de representación gráfica de datos en tiempo real.
  • KTorrent: cliente para el protocolo de intercambio de archivos BitTorrent.
  • reKonq: navegador web ligero basado en el motor WebKit.
  • Skanlite: aplicación simple de escaneo de imágenes.
  • Smb4k: navegador de red para recursos compartidos Samba.
  • Tellico: gestor de colecciones.
  • Yakuake: emulador de terminal desplegable.
Versión actualizada de KTorrent en openSUSE 12.2.
Para instalar versiones actualizadas de las aplicaciones KDE en openSUSE hay que seguir los pasos siguientes.

1. Iniciar sesión como superusuario en el terminal.

su -

2. Añadir el repositorio de aplicaciones actualizadas de KDE.


3. Refrescar los repositorios.

zypper refresh

5. Actualizar las aplicaciones KDE desde el nuevo repositorio añadido.

zypper dup --from KDE:UpdatedApps

4 comentarios:

  1. Buena, gracias por la info. ¿Si tengo KDE 4.9 no es recomendable este repositorio? Un saludo

    ResponderEliminar
    Respuestas
    1. Si tienes KDE 4.9 no ni recomendable ni necesario este repositorio, pues el repositorio de KDE 4.9 ya dispone de las aplicaciones actualizadas. Incluyo la aclaración en el artículo.

      Un saludo.

      Eliminar
  2. Hola toniem, buenas noches. Te copio parte del articulo que publicas porque no logre comprender bien.

    "El equipo KDE proporciona nuevas versiones de las aplicaciones KDE que no forman parte de la compilación de software de KDE en el repositorio semioficial KDE:UpdatedApps. Este repositorio sólo es compatible con la versión del entorno KDE incluído con la distribución y es muy estable."

    Esto quiere decir que si yo instalo OpenSuse, y lo mantengo en su estado original, activando ese repositorio "UpdateApps" este, actualizaría los paquetes que instale oficial y originalmente, sin perder la estabilidad del Sistema Operativo?, es así?

    Te comento esto, porque he notado en algunos casos que la actualización a KDE4.9, y trabajando diariamente en el, me deja un sabor raro, como que no me convence tener un entorno de escritorio actualizado a la ultima versión y el resto de los paquetes que conforman el SO, están versiones atrás, generando en algunos casos, conflictos entre dependencias. Dejando una leve sensación de inestabilidad.

    Aguardo tus comentarios, un saludo
    Germán.

    ResponderEliminar
    Respuestas
    1. Hola Germán. Este repositorio es para actualizar algunas aplicaciones KDE sin actualizar la versión del entorno. Es una opción más prudente que actualizar todo el entorno KDE para poder disfrutar de una nueva versión de Amarok, por ejemplo.

      Si has actualizado a KDE 4.9 y deseas utilizar este repositorio, primero deberás desactualizar la versión de KDE instalada. Consulta: http://guiadelcamaleon.blogspot.com.es/2012/10/eliminar-actualizacion-kde-gnome-opensuse.html.

      De todas maneras, yo llevo utilizando KDE 4.9 bastante tiempo y no he notado las incompatiblidades que mencionas. ¿Puedes concretarlas?

      La versión 4.9 de KDE que hay en los repositorios es muy estable, sobre todo ahora, que ya va por la versión 4.9.4. Normalmente cualquier pequeño fallo lo subsanan al poco tiempo. Conviene actualizar la distribución con "zypper up" cada cierto tiempo (por ej. cada semana). Además KDE 4.9 funciona más fluido en todos los ordenadores donde lo he instalado.

      Espero haberme explicado bien. Un saludo.

      Eliminar