Páginas

domingo, 14 de abril de 2013

Cómo instalar GNOME 3.8 en openSUSE 12.3 [Actualizado]

El pasado 27 de marzo el proyecto GNOME anunció la publicación de la cuarta actualización de GNOME 3.0, versión publicada originalmente en abril de 2011.

Esta versión de GNOME 3 es el resultado de seis meses de esfuerzo de desarrollo e incorpora numerosas características nuevas, así como gran cantidad de pequeñas mejoras y correcciones de error. Entre todas las novedades destacamos dos: la implementación de un nuevo modo clásico para los usuarios que prefieran una interfaz más tradicional y las nuevas posibilidades de configuración del entorno.

Puedes obtener más información sobre las características de esta versión en las notas de publicación, que están disponibles en español.

Nueva vista de lanzamiento de aplicaciones en GNOME 3.8. La pestaña Frecuentes incluye las aplicaciones más usadas y la pestaña Todas muestra todas las aplicaciones.

GNOME 3.8 ya se encuentra disponible para los usuarios de openSUSE 12.3 en los repositorios semioficiales de GNOME:STABLE. Los pasos para actualizar a esta versión son los siguientes. El requisito previo es tener instalada la versión actualizada de GNOME 3.6.

1. Iniciar sesión como superusuario en el terminal.

su - 

2. Añadir el nuevo repositorio de GNOME 3.8.

zypper ar -f http://download.opensuse.org/repositories/GNOME:/STABLE:/3.8/openSUSE_12.3 GNOME38

3. Actualizar la distribución desde el nuevo repositorio.

zypper dup --from GNOME38

4. Añadir las traducciones para el interfaz de usuario.

zypper in gnome-shell-lang

5. Instalar el modo clásico para que esté disponible en el gestor de sesiones.

zypper in gnome-shell-classic

Gestor de sesiones de GNOME 3.8 en openSUSE 12.3.
Interfaz clásica de GNOME 3.8 en openSUSE 12.3

SOLUCIÓN DE ERRORES

Cualquier error que se encuentre se puede comunicar al equipo GNOME de openSUSE a través del chat (#openSUSE-gnome@irc.freenode.net), el correo (openSUSE-gnome@opensuse.org) o la página de errores de Novell (bugzilla.novell.com; indicar el repositorio desde el que se ha instalado esta versión de GNOME).

1. Adaptadores gráficos de Intel.

Si se producen bloqueos durante el inicio del entorno, hay que añadir esta opción en "Parámetros opcionales en la línea de comandos del kernel" en la pestaña "Opciones del cargador de arranque" del módulo Cargador de arranque de YaST:

i915.i915_enable_rc6=0

Otra opción para solucionar el problema es actualizar la biblioteca gráfica Mesa.

zypper ar obs://home:dimstar:Mesa/standard Mesa

zypper dup --from Mesa


De todas formas, el problema de GNOME 3.8 con los adaptadores gráficos de Intel en openSUSE 12.3 se ha solucionado con una actualización oficial. Por tanto, para evitarlo sólo hay que asegurarse de tener el sistema actualizado antes de instalar esta versión de GNOME.

2. Módems 3G.

Si ahora no se puede establecer una conexión con el módem 3G mediante NetworkManager, hay que desactualizar el paquete ModemManager que se instala desde el repositorio GNOME38 instalando de nuevo la versión oficial 0.6.0.0.

ACTUALIZACIÓN

23-10-2013. Añadida nota aclaratoria sobre el problema con los adaptadores gráficos Intel.

Fuentes:

24 comentarios:

  1. Lo podria probar en Opensuse 12.3 pero con KDE??

    ResponderEliminar
    Respuestas
    1. Sí, primero instala desde YaST el patrón "Entorno de escritorio GNOME" y después de terminar la instalación, sigue los pasos explicados aquí.

      Eliminar
    2. ok, gracias lo intentare :D

      Eliminar
    3. si lo hiciste al final, no quedo algo batido? lo quiero intentar tambi+en.

      Eliminar
    4. YO instale KDE inicialmente, como me gusta gnome, instale Gnome 3 pensé que se iba a batir e inicialmente asi parecia, pues cargaba muchas cosas de kde aunque funcionaba bien, decidí desinstalar KDE y entonces el gestor de sesiones se fue, creí nuevamente que se había batido, pero no fue asi solo cambia el KDM por el GDM y listo... NUNCA SE BATIÓ... una chulada. Solo detealles con el kwallet nada que no se pueda solucionar creando otro wallet en gnome

      Eliminar
  2. Andres Lazo18/4/13 3:43

    Muchisimas gracias por la información de los controladores MESA! :D

    ResponderEliminar
  3. ¿al actualizar gnome de 3.6 a 3.8, no afecta las aplicaciones ya instaladas, como skype, etc.., así como los archivos guardados? Saludos!

    ResponderEliminar
  4. Por supuesto que los documentos guardados no se ven afectados. Y las aplicaciones instaladas serán actualizadas si son de GNOME. Skype no depende de GNOME. Un saludo.

    ResponderEliminar
  5. Gracias por compartir tu conocimiento en forma tan sencilla y efectiva!

    ResponderEliminar
  6. Excelente carnal, gracias por el aporte chidisimo, un saludo :)

    ResponderEliminar
  7. Habrá algún modo de hacer la configuración del entorno gráfico más amigable como en KDE? es que el gnome-tweak-tool no es muy detallista.

    ResponderEliminar
    Respuestas
    1. Hola, Fernando. Yo no conozco ninguna herramienta mejor. Los desarrolladores del entorno GNOME no desean una configuración avanzada fácil para los usuarios. Esa es su opción. Entre otras cosas, por eso preferiero KDE, que con un par de clics lo personalizas a gusto del usuario. Un saludo.

      Eliminar
  8. Gracias por el tutorial, me sirvió perfectamente. Lo único que algunas extensiones de Gnome Shell no funcionan en la 3.8

    ResponderEliminar
    Respuestas
    1. No hay de qué. Estos chicos y chicas de GNOME son unos pillos no garantizan la compatibilidad entre versiones. Un saludo.

      Eliminar
  9. Saludos. Segui al pie de la letra tu explicacion, todo bien, pero no paso del gestor de sesiones, al momento de introducir usuario y pass, me sale una pantalla que dice "¡Oh No Something Is Wrong!" y es todo lo que pasa. Cabe decir que me desconfiguro todo y tuve que reinstalar T.T Creo que tendre que esperar para probarlo.... :(

    ResponderEliminar
    Respuestas
    1. Para eliminar una actualización de GNOME o KDE fácilmente se puede consultar este artículo:

      http://guiadelcamaleon.blogspot.com/2012/10/eliminar-actualizacion-kde-gnome-opensuse.html

      Un saludo.

      Eliminar
  10. Hola, gracias por el aporte, veras segui todos los pasos
    y al agregar el repositorio de mesa no me dejo ponerlo y por lo tanto puse:
    i915.i915_enable_rc6=0
    en los parametros del kernel en YAST
    el problema es que despues al acer
    zypper dup
    instala unas cuantas cosas
    y al reiniciar se queda trabado antes del gmd
    reverti esto haciendo de nuevo
    zypper dup --from GNOME38
    me podrias decir si hay alguna manera de hacer esto
    por favor :D

    ResponderEliminar
    Respuestas
    1. Qué quiere decir que no te dejó poner el repositorio de Mesa? De todas maneras si has colocado los parámetros opcionales para el adaptador intel, no hace falta actualizar Mesa.

      Por otra parte, no se debe NUNCA hacer zypper dup, así sin más parámetros, pues, dependiendo de los repositorios que tengas habilitados, se puede romper el sistema.

      Después de hacer "zypper dup --from GNOME38" se te ha arreglado el problema? Si no es así, deberías desactivar todos los repostorios no oficiales y hacer "zypper dup". También deberías repasar los paquetes marcados en rojo en YaST. A ver si tienes suerte. Un saludo.

      Eliminar
    2. bueno, si me agrega el repositorio
      pero al hacer :
      zypper dup --from Mesa
      me saca esto

      Error construyendo el caché:
      [|] Valid metadata not found at specified URL
      AdvertenciaDeshabilitando el repositorio 'Mesa' debido al error anterior.
      Obteniendo los datos del repositorio...
      Leyendo los paquetes instalados...
      Calculando actualización...

      No hay nada que hacer.

      Y bueno, como esto no funciono puse los parámetros opcionales y no hubo problema.

      No sabia que no se debía hacer zypper dup sin paramentos, vengo de fedora así que soy nuevo en suse.

      Al hacer zypper dup --from GNOME38 se arreglo todo ya no tengo problemas con eso.

      Gracias por la información.

      Eliminar
    3. No hay de qué. Me alegro que se arreglara todo. Un saludo.

      Eliminar
    4. Acabo de consultar las fuentes del artículo y a actualizarlo. El problema con los adaptadores Intel no se produce si se tiene el sistema actualizado. El repositorio que se indicaba ha sido eliminado. Un saludo.

      Eliminar